INC400010 - Degradation to Form3 - SEPA Instant

Incident Report for Form3

Postmortem

Following further analysis, we can confirm that the Form3 - SEPA Instant Service was unaffected. The issue observed was related to a customer owned incident.

Posted Aug 26, 2025 - 11:30 UTC

Resolved

The issue affecting Form3 - SEPA Instant service has been resolved.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Aug 25, 2025 - 16:27 UTC

Monitoring

We can confirm service has returned to normal processing and no further impact.

We continue to monitor the service to ensure no further degradation is observed.
Posted Aug 25, 2025 - 16:14 UTC

Update

We continue to investigate the degradation to the Form3 - SEPA Instant service.

This is impacting Admissions only, there is no impact to Submissions.
Posted Aug 25, 2025 - 15:45 UTC

Investigating

Form3 are investigating a performance degradation to the Form3 - SEPA Instant service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Aug 25, 2025 - 15:02 UTC
This incident affected: Form3 - SEPA Instant (Direct (IRE), Direct Non Settling (IRE), Direct (LON), Direct Non Settling (LON)).