FPS Indirect Payment delay
Incident Report for Form3 - Financial Cloud
Resolved
We have confirmed that the maintenance has been successfully completed, all delayed payments have been processed and the platform is now operating as normal
Posted 3 months ago. May 02, 2019 - 08:07 UTC
Monitoring
As advised to impacted customers, due to essential maintenance being conducted by our FPS Indirect partner, we are currently experiencing a delay to outbound payments, inbound payments are unaffected
Our Incident Response Team are monitoring payment delays and we will post an update once the situation is resolved or changes
Posted 3 months ago. May 02, 2019 - 07:25 UTC
This incident affected: FPS RT - Indirect.