Authentication Service Degradation
Incident Report for Form3
Postmortem

From 01:59 - 02:18 BST, Form3’s authentication provider experienced an internal degradation preventing new tokens from being generated.

There was no impact to payment processing during this issue, customers sending token requests during this time would receive a 502 error. Tokens generated before 01:59 BST continued to function without issue.

The provider restored service and following a period of monitoring confirmed no further degradation was seen.

Form3 continue to investigate enhancements to our authentication process and work with our provider to ensure mitigations are put in place to prevent further recurrence.

Posted May 06, 2020 - 13:22 UTC

Resolved
Between 01:59 and 02:18 BST we experienced a degradation to our authentication service.

During this period customers would not have been able to create new tokens, existing tokens would not have been affected.

Our Incident Response Team closely monitored payment flow and confirmed that there were no failed payments due to this degradation.
Posted May 06, 2020 - 01:44 UTC
This incident affected: _Archived Components (FPS RT - Indirect - Starling, FPS RT - Direct, Account Management Services, Bacs - Direct Participant, Reports, SEPA Instant - Direct).