46503 - Degradation to the Platform
Incident Report for Form3
Postmortem

On Tuesday 21 June, Form3 identified a platform wide performance degradation.

Services impacted were FPS RT - Direct 2 and SEPA Instant - Direct.

Between 06:30 - 07:13 UTC, payments were being processed successfully however, some customers may have experienced a high volume of failed or delayed admissions and submissions.

Root cause was isolated to an issue with our External Provider. To restore services, Form3 implemented an interim solution at 07:13 UTC while our External Provider was working on implementing a fix. Payment processing then returned to expected levels.

The External Provider implemented a fix at 06:57 UTC and following a period of stability monitoring confirmed the issue to be fixed at 08:06 UTC.

Root cause analysis (RCA) has been provided by our External Provider with remediation and follow up actions to prevent a reoccurrence.

Posted Jun 22, 2022 - 14:12 UTC

Resolved
The issue across the platform has been resolved as of 07:13 UTC.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Jun 21, 2022 - 07:55 UTC
Monitoring
We can confirm service has returned to normal processing since 07:13 UTC.

We continue to monitor the service to ensure appropriate mitigation is in place and no further degradation is observed.
Posted Jun 21, 2022 - 07:33 UTC
Identified
We have isolated the issue across the platform to a 3rd Party Provider outage and are taking actions to mitigate impact as quickly as possible.

We will post an update when further information is available.
Posted Jun 21, 2022 - 07:21 UTC
Investigating
Form3 are investigating a performance degradation across the platform.

Admissions and submissions are not processing.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Jun 21, 2022 - 06:59 UTC
This incident affected: _Archived Components (FPS RT - Direct - 2, FPS RT - Indirect - LHV, SEPA Instant and SEPA Credit Transfer - Indirect - LHV, SEPA Instant - Direct, SEPA Credit Transfer - Direct, SEPA Direct Debit - Core / B2B, SEPA Credit Transfer - DNSP).