Platform Degradation
Incident Report for Form3 - Financial Cloud
Postmortem

From 11:09 UTC – 11:19 UTC our platform experienced increased load due to internal components excessively retrying operations, this caused some operations to timeout.

We have reviewed the internal retry logic of these components and are working to implement improvements that will prevent a recurrence in the future.

We continue to monitor the situation closely for further issues

Posted May 01, 2019 - 12:06 UTC

Resolved
We have identified an issue that intermittently impacted payment processing between 11:09 and 11:19 UTC. The issues has now been resolved and we are continuing to monitor the platform.
Posted Apr 30, 2019 - 12:09 UTC