Bacs Service Degradation
Incident Report for Form3 - Financial Cloud
Resolved
This investigation has now been completed and we can confirm there was no service impact.
Posted about 1 year ago. Sep 26, 2018 - 15:33 UTC
Investigating
We are currently experiencing a degradation of our Bacs service. We are investigating but do not believe this is service impacting at this time.
Posted about 1 year ago. Sep 26, 2018 - 10:37 UTC
This incident affected: Bacs - Direct Participant.