INC394174 - Outage to Form3 - Metrics

Incident Report for Form3

Postmortem

On Monday 28th July, Form3 observed an outage to the Form3 Metrics API service between 17:29 and 19:53 UTC.

The issue has been resolved and after a period of monitoring, our Incident Response Team have confirmed there is no ongoing impact.

Further details will be provided in the postmortem in due course.

Posted Jul 29, 2025 - 07:05 UTC

Resolved

The issue affecting Form3 - Metrics service has been resolved as of 19:53 UTC.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Jul 28, 2025 - 20:08 UTC

Monitoring

A fix has been implemented and we are in a period of monitoring.

Impacted customers should now see that normal processing has resumed on the Form3 - Metrics service.

We will provide an update on resolution in due course.
Posted Jul 28, 2025 - 20:01 UTC

Investigating

Form3 are investigating a outage to the Form3 - Metrics service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Jul 28, 2025 - 18:15 UTC
This incident affected: Form3 - Metrics.