INC312818 - Degradation to Form3 - UK Instant

Incident Report for Form3

Postmortem

On Monday 23rd September, Form3 observed a degradation to the Form3 UK Instant service to outbound payment flows between 09:00 and 09:54 UTC.

Service was restored at 09:54 UTC with no further impact to payments.

Root cause is being investigated by Form3 to identify preventative measures and put in place mitigation to prevent future issues.

Posted Sep 23, 2024 - 12:43 UTC

Resolved

This incident has been resolved.
Posted Sep 23, 2024 - 09:58 UTC

Update

A fix was successfully applied and service is now confirmed as restored.
Posted Sep 23, 2024 - 09:58 UTC

Update

We have identified the issue, and are working on the fix as a priority.

We will post an update at 11:15 unless there is further information to share before this time.
Posted Sep 23, 2024 - 09:51 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 23, 2024 - 09:41 UTC

Identified

Form3 are investigating a performance degradation to the Form3 - UK Instant service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Sep 23, 2024 - 09:33 UTC
This incident affected: Form3 - UK Instant (Direct (IRE), Direct (LON), Direct (MQ), Direct (WS)).