Degradation to FPS Indirect
Incident Report for Form3 - Financial Cloud
Postmortem

Our FPS Indirect partner experienced a degradation to their internal processing of payment submissions between 08:40 UTC and 19:30 UTC on the 20/08/19, this introduced a delay of up to 120 seconds to payment processing but did not prevent payments reaching a final status.

Our partner identified the root cause of the problem and put in place some temporary mitigations on the 21/08/19, while they implement a permanent fix.

We have also introduced new monitoring to ensure we are alerted as soon as possible should we see slow payment processing in the future.

Posted about 1 month ago. Aug 21, 2019 - 11:26 UTC

Resolved
Our FPS indirect service has recovered and normal service has resumed. 

Our Indirect partner is confident they have put in place the necessary mitigations while they investigate a longer term fix

We will continue to monitor the service to ensure there is no ongoing impact.
Posted about 1 month ago. Aug 21, 2019 - 09:53 UTC
Update
We continue to monitor a delay to payment submissions on our FPS Indirect service.

Our Indirect partner continues to investigate this issue and are working to implement mitigations.

Customers can expect potential short delays to payment submissions however there is no impact to payment processing other than this delay

We continue to monitor the impact of this degradation and will post an update once we have confirmed mitigation is in place and customers can expect processing times to return to normal
Posted about 1 month ago. Aug 20, 2019 - 17:30 UTC
Monitoring
We continue to monitor a degradation of our FPS Indirect partner causing an increased delay to payment submissions.

Our partner continues to investigate the issue and we will provide a meaningful update once available
Posted about 1 month ago. Aug 20, 2019 - 14:21 UTC
Update
We have identified an issue with our FPS Indirect partner causing a delay to payment submissions. We are working closely with our partner to resolve this issue as soon as possible.

Customers may see submissions taking approximately a minute to reach a final status while this degradation continues

We will post an update at 15:20 BST unless there is further information to share before this time
Posted about 1 month ago. Aug 20, 2019 - 13:23 UTC
Identified
We are currently experiencing a degradation of our FPS Indirect service.

We are seeing a delay in payment submissions before reaching a final state

Our team are investigating and will provide updates as the investigation progresses
Posted about 1 month ago. Aug 20, 2019 - 13:08 UTC
This incident affected: FPS RT - Indirect.