Authentication Service Degradation
Incident Report for Form3
Postmortem

Identified that between 23:30 and 00:15 UTC, the authentication provider used to generate tokens on login to the Form3 api experienced an internal degradation in the region Form3 is hosted. As a result our alerting identified intermittently failing tests during this period.

The Incident Response team monitored the situation until the provider confirmed the issue had been resolved and all requests were being handled successfully.

We continue to work with the provider to ensure mitigations are in place going forward

Posted Mar 12, 2020 - 10:14 UTC

Resolved
Between 23:30 and 00:15 UTC we experienced a brief degradation to our authentication service.

During this period customers would not have been able to create new tokens, existing tokens would not have been affected.

No further disruption is anticipated.
Posted Mar 12, 2020 - 00:28 UTC
This incident affected: _Archived Components (FPS RT - Indirect - Starling, FPS RT - Direct, Account Management Services, Bacs - Direct Participant, Reports, SEPA Instant - Direct).