Account Validation Degradation
Incident Report for Form3
Postmortem

From 14:30 - 14:34 UTC, Form3 experienced an intermittent degradation in performing account validation on a small number of payment admissions. This led to some admissions timing out and reversing, submissions were unaffected.

This degradation was as a result of a long running function on the service reducing available processing capacity. The function was stopped and admission validation processing resumed processing as normal.

Our team are investigating enhancements to the service to optimise service functionality in light of behaviour seen.

Posted Apr 21, 2020 - 13:44 UTC

Resolved
We saw an intermittent degradation to our SEPA Instant Service and FPS Direct Service from 14:30-14:34 UTC which has now recovered and normal service has resumed. 

During this period, we saw some payment admissions time out and submissions were unaffected.

We will continue to monitor the service to ensure there is no ongoing impact.
Posted Apr 20, 2020 - 15:18 UTC
Investigating
Form3 have received an alert related to the FORM3 Platform.

Investigations are ongoing and an update will be provided when more information becomes available.
Posted Apr 20, 2020 - 14:47 UTC
This incident affected: _Archived Components (FPS RT - Direct, SEPA Instant - Direct).