INC470455 - Degradation Across Multiple Form3 Services

Incident Report for Form3

Postmortem

On Wednesday 8th July, Form3 observed degradation to multiple services between 21:16-21:33 UTC.

The issue has been resolved by our Third Party Provider, and after a period of monitoring, our Incident Response Team have confirmed there is no ongoing impact.

Further details will be provided in the postmortem in due course.

Posted Jul 09, 2026 - 10:34 UTC

Resolved

Between 21:16 and 21:33 UTC, Form3 experienced a service degradation affecting multiple services.

During this time, some customers may have experienced increased latency across the impacted services.

The issue has now been resolved, and after a period of monitoring we have confirmed there is no ongoing impact.

We are conducting a full review of the incident and will share further details in due course.
Posted Jul 08, 2026 - 21:16 UTC
This incident affected: Form3 - Verification of Payee (VoP Responder, VoP Requester), Form3 - UK Instant (Direct, Direct (MQ), Direct (WS)), Form3 - Confirmation of Payee (CoP Responder (LON), CoP Requester (LON)), Form3 - UK Bacs (Direct (LON), Direct Non Settling (LON)), Form3 - SEPA Instant (Direct (LON), Direct Non Settling (LON)), Form3 - SEPA (Direct Debit - Direct Non Settling (LON), Credit Transfer - Direct Non Settling (LON), Direct Debit - Direct (LON), Credit Transfer - Direct (LON)), and Form3 - Metrics, Form3 - Account Management Services, Form3 - Reports.