INC100011 - Degradation to the Form3 - Confirmation of Payee Service
Incident Report for Form3
Postmortem

On Thursday 6th March 2023, Form3 identified an issue impacting the Form3 - CoP service. Investigation found that following a certificate rotation, authentication to the service was degraded based on how individual banks authenticate against the CoP service.

A change was made, and subsequently the new certificate was redeployed to fully restore the authentication service.

Posted Apr 11, 2023 - 15:29 UTC

Resolved
The issue affecting Form3 - Confirmation of Payee service has been resolved.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Apr 06, 2023 - 14:41 UTC
Monitoring
A fix has been implemented and we are in a period of monitoring.

Impacted customers should now see that normal processing has resumed on the Form3 - Confirmation of Payee service.

We will provide an update on resolution in due course.
Posted Apr 06, 2023 - 14:29 UTC
Identified
We have isolated an issue on the Form3 - Confirmation of Payee service that is causing performance degradation.

Our Incident Response team is actively working to resolve this as high priority.

We will post an update as soon as there is further information to share.
Posted Apr 06, 2023 - 13:24 UTC
Update
We continue to investigate root cause as high priority.

Customers may experience degradation to the Confirmation of Payee Service whilst investigations are ongoing.

We will provide an update as soon as more information becomes available.
Posted Apr 06, 2023 - 12:47 UTC
Investigating
Form3 are investigating a performance degradation to the Confirmation of Payee service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Apr 06, 2023 - 12:22 UTC
This incident affected: Form3 - Confirmation of Payee (CoP Responder).