Platform Degradation
Incident Report for Form3
Postmortem

From 14:37-14:40 BST and then again at 15:04 to 15:17 BST, Form3 experienced a degradation where account validation services were temporarily unavailable for payment processing.

This resulted in a small number of admissions not being handled within normal timeframes, timing out and showing as reversed in the Form3 API.

Form3 identified that this was as a result of unexpected platform behaviour linked to a routine release. The release was rolled back, the service stabilised and processing resumed as normal.

We are reviewing the change as well as our testing suite to ensure this behaviour is identified as part of the change testing process in any future releases.

Posted Apr 17, 2020 - 10:27 UTC

Resolved
No further issues have been seen since 15:17 BST. We experienced an internal degradation to service caused by a routine platform release.

Admissions timed-out intermittently while submissions remained unaffected during two windows of impact which lasted between 14:37 to 14:40 and 15:04 to 15:17 BST.

Our Incident Response Team continue to monitor for any further issues.
Posted Apr 16, 2020 - 14:41 UTC
Investigating
Form3 have received an alert related to the FORM3 Platform.

Investigations are ongoing and an update will be provided when more information becomes available.
Posted Apr 16, 2020 - 14:12 UTC
This incident affected: _Archived Components (FPS RT - Indirect - Starling, FPS RT - Direct, Account Management Services, Bacs - Direct Participant, Reports, SEPA Instant - Direct).