Payment Services Degradation
Incident Report for Form3 - Financial Cloud
Postmortem

During 15:47 - 15:50 UTC we saw a very small number of payments impacted by a change made by our third party supplier which in turn, caused some authentication errors in our system when attempting to validate beneficiary party account details.

These errors caused a small number of payments to incorrectly fail validation.

We located the root cause and implemented a fix quickly to reduce the impact.

Thank you.

Posted 7 months ago. Mar 08, 2019 - 14:29 UTC

Resolved
After a period of monitoring, we have not seen any further degradation in our service. This is now resolved.
Posted 7 months ago. Mar 07, 2019 - 20:46 UTC
Monitoring
We have experienced a brief degradation in our payment services as a result of a change made to our validation process.

We have resumed normal service and do not anticipate any further disruption. Thank you.
Posted 7 months ago. Mar 07, 2019 - 17:46 UTC
This incident affected: FPS RT - Indirect, FPS RT - Direct, and Bacs - Direct Participant.