INC256026 - Degradation to Form3 - SEPA Instant - Direct and Form3 - SEPA Instant - Direct Non Settling services
Incident Report for Form3
Postmortem

On Tuesday 4th June, Form3 experienced degradation to the Form3 - SEPA Instant - Direct and Form3 - SEPA Instant - Direct Non Settling services causing a delay to outbound payment processing between 15:07 and 15:26 UTC.

Services auto-recovered at 15:26 UTC with no further impact to payment processing.

Root cause is being investigated by Form3 in a bid to ensure mitigating actions are identified and implemented to prevent any future reoccurrence.

Posted Jun 05, 2024 - 15:19 UTC

Resolved
From 15:07 to 15:26 UTC, Form3 experienced a degradation to the Form3 - SEPA Instant - Direct and Form3 - SEPA Instant - Direct Non Settling services.

During this period, customers may have experienced latency with outbound payment processing. Inbound payments were not impacted.

The issue was resolved at 15:26 UTC and after a period of monitoring, our Incident Response Team have confirmed there is no ongoing impact.

Further details will be provided in the postmortem in due course.
Posted Jun 04, 2024 - 18:14 UTC
This incident affected: Form3 - SEPA Instant (Direct, Direct Non Settling).