INC284868 - Certificate Validation Issue
Incident Report for Form3
Postmortem

On Tuesday 30th July, Form3 received communication of an incident logged by our third party provider impacting previously issued certificates that had been issued with missing validation requirements.

Form3 took remedial action which was completed by 16:14 BST, followed by a period of enhanced monitoring.

Post incident analysis is underway by our provider to establish full root cause in a bid to identify any mitigating actions to prevent reoccurrence.

Posted Jul 31, 2024 - 17:55 UTC

Resolved
Form3 have completed all remediation activities and can confirm this issue is now resolved.

Full root cause will be shared via the postmortem in due course.
Posted Jul 30, 2024 - 16:19 UTC
Update
Form3 remediation activities are being progressed as a priority.

An update will be provided once this has been completed.
Posted Jul 30, 2024 - 12:49 UTC
Identified
We are continuing to work on remediation a priority.

A further communication has been sent directly to customers.
Posted Jul 30, 2024 - 10:55 UTC
Investigating
We have received a notification from our third party provider advising they have raised an incident related to certificates they have issued with missing validation requirements.

Initial analysis has confirmed there is no current impact to payment processing. We are continuing to investigate as a priority and will follow up directly with impacted customers.
Posted Jul 30, 2024 - 09:34 UTC
This incident affected: Form3 - UK Instant (Direct (IRE), Direct (LON)), Form3 - SEPA (Credit Transfer - Direct, Credit Transfer - Direct Non Settling, Direct Debit - Direct), Form3 - UK Bacs (Direct (IRE), Direct Non Settling (IRE)), Form3 - SEPA Instant (Direct, Direct Non Settling), Form3 - Account Management Services, Form3 - Reports, and _Archived Components (Direct Non Settling).