INC447366 - Degradation to Form3 - SEPA Instant

Incident Report for Form3

Resolved

The issue affecting Form3 - SEPA Instant service has been resolved.

We have received confirmation from the Scheme that the issue has been resolved.

Following a period of monitoring, we can confirm that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Apr 18, 2026 - 22:22 UTC

Update

We are still awaiting for Scheme (external to Form3) to fix the issue.

We will post an update once more information becomes available from them.
Posted Apr 18, 2026 - 21:26 UTC

Identified

Scheme (external to Form3) have identified an issue and are working on a resolution.

We will post an update once more information becomes available from them.
Posted Apr 18, 2026 - 20:23 UTC

Investigating

We are currently investigating an issue on the Form3 - SEPA Instant service which is impacting some inbound and outbound payments.
Posted Apr 18, 2026 - 20:18 UTC
This incident affected: Form3 - SEPA Instant (Direct (LON), Direct Non Settling (LON)).