Payment Validation Degradation
Incident Report for Form3
Postmortem

From 14:56 UTC - 15:14 UTC our validation provider identified an issue within their configuration, this caused an intermittent degradation of payment submission validation. At 15:14 UTC a temporary fix was implemented and the degradation was resolved.

At 16:38 UTC a complete fix was implemented with no further impact to the service.

Our Incident Response team continued to monitor throughout the weekend and experienced no further impact to the service. We are working closely with our provider to ensure further preventative measures are in place going forward

Posted Apr 29, 2019 - 13:59 UTC

Resolved
We identified an issue with our validation provider which intermittently impacted outbound payments with incorrect validation failure

We have put in place a work around to prevent further incorrect validation failure and will continue to monitor this over the weekend to confirm there is no ongoing impact.

We are working with our validation provider to investigate the root cause and review further mitigation measures
Posted Apr 26, 2019 - 16:15 UTC
Monitoring
We have identified the root cause of this problem and have applied a fix. We will continue to monitor to ensure no further impact
Posted Apr 26, 2019 - 15:24 UTC
Investigating
We are currently experiencing a degradation of our payment validation service that is intermittently affecting outbound payments. We are investigating the situation and will keep you updated. Thank you for your patience.
Posted Apr 26, 2019 - 15:09 UTC
This incident affected: _Archived Components (FPS RT - Indirect - Starling, FPS RT - Direct).