INC54248 - Degradation to the FPS Direct & Indirect service
Incident Report for Form3
Postmortem

On Friday 19 August, Form3 identified a performance degradation on the FPS Direct and Indirect services.

This resulted in a delay to inbound and outbound payment processing between at 7:05 UTC and 08:56 UTC.

The root cause was isolated to a planned security policy update which resulted in unexpected impact with our cloud provider.

Inbound payment processing returned to normal state at 07:45 UTC. Remedial actions were taken by Form3 at 8:56 UTC and all impacted outbound payments were processed at 10:30 UTC.

Further stability monitoring confirmed no ongoing issues. Mitigations are in place to prevent any reoccurrence.

Posted Aug 22, 2022 - 11:14 UTC

Resolved
The issue affecting the FPS Direct & Indirect services has been resolved.

We have confirmed, following a period of monitoring, that the services have returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Aug 19, 2022 - 10:40 UTC
Monitoring
Form3 have implemented a fix.

All queued outbound payments are now processing to final state. All inbound payments have been received successfully.

We are currently monitoring the platform to ensure no further impact is observed.
Posted Aug 19, 2022 - 09:05 UTC
Update
We are continuing to work on a fix for this issue as a high priority.

Submissions are currently not being processed and admissions processing is delayed.

Any updates will be provided as soon as one becomes available.
Posted Aug 19, 2022 - 08:35 UTC
Identified
We have isolated an issue on the FPS Direct & Indirect service that is causing performance degradation.

Submissions are currently not being processed and admission processing is delayed.

Our Incident Response team is actively working to resolve this as high priority.

We will post a further update shortly.
Posted Aug 19, 2022 - 08:06 UTC
Investigating
Form3 are investigating a performance degradation to the FPS Direct & Indirect service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Aug 19, 2022 - 07:42 UTC
This incident affected: _Archived Components (FPS RT - Direct - 2, FPS RT - Indirect - LHV).