INC438091 - Service Degradation on the Form3 - Metrics Service

Incident Report for Form3

Resolved

The issue affecting Form3 - Metrics service has been resolved.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Mar 01, 2026 - 16:11 UTC

Monitoring

A fix has now been implemented and we are continuing to monitor the situation closely.

Impacted customers should see that performance has returned to normal within the Form3 Metrics service.

We will continue to monitor the service and provide further updates if necessary.
Posted Mar 01, 2026 - 16:03 UTC

Investigating

Form3 are investigating a service degradation on the Form3 - Metrics service that began at circa 14:40 UTC.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Mar 01, 2026 - 14:40 UTC
This incident affected: Form3 - Metrics.