INC310026 - Degradation Across Multiple Form3 Services
Incident Report for Form3
Postmortem

On Monday 16th of September 2024, Form3 were alerted to a degradation to the Form3 - UK Instant - Direct (IRE) and Form3 - SEPA Instant - Direct services between 04:07 and 05:07 UTC.

Root cause investigation is underway by Form3 to identify root cause and any preventative measures to prevent any future reoccurrence.

Posted Sep 18, 2024 - 15:30 UTC

Resolved
We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Sep 16, 2024 - 05:41 UTC
Monitoring
A fix has been implemented and we are now in a period of monitoring.

Impacted customers should now see that normal processing has resumed across the impacted services.

We will provide an update on resolution in due course.
Posted Sep 16, 2024 - 05:31 UTC
Identified
We have identified the cause of the performance degradation and are actively working to resolve this as a high priority.

A further update will be provided by 06:30 BST.
Posted Sep 16, 2024 - 05:06 UTC
Update
We are continuing to investigate this issue.
Posted Sep 16, 2024 - 04:53 UTC
Investigating
Form3 are investigating a performance degradation across multiple services.

Customers may experience latency when processing inbound and outbound payments.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Sep 16, 2024 - 04:51 UTC
This incident affected: Form3 - UK Instant (Direct (IRE)), Form3 - SEPA (Credit Transfer - Direct, Credit Transfer - Direct Non Settling, Direct Debit - Direct), Form3 - UK Bacs (Direct (IRE), Direct Non Settling (IRE)), and Form3 - SEPA Instant (Direct, Direct Non Settling).