INC395498 - Degradation to SEPA Instant

Incident Report for Form3

Postmortem

On Thursday 1st August, Form3 experienced degradation to the Form3 - SEPA Instant services.

EBA clearing identified an issue that was impacting payment processing between 13:30 and 14:20 UTC

Following a period of monitoring, Form3 confirmed that payments were processing as expected.
The cause of this degradation has been mitigated by EBA clearing.

Posted Aug 04, 2025 - 11:38 UTC

Resolved

The issue affecting SEPA Instant service has been resolved as of 14:20 UTC.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Aug 01, 2025 - 14:55 UTC

Monitoring

EBA Clearing have confirmed that they are investigating an issue that is causing a degradation to the SEPA Instant service and restoration work is ongoing.

We are monitoring the situation and will provide more information as details are provided.
Posted Aug 01, 2025 - 14:42 UTC

Investigating

Form3 are investigating a performance degradation to the SEPA Instant service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Aug 01, 2025 - 14:11 UTC
This incident affected: Form3 - SEPA Instant (Direct (IRE), Direct Non Settling (IRE), Direct (LON), Direct Non Settling (LON)).