Degradation to the FORM3 Egress Proxy
Incident Report for Form3
Postmortem

From 13:39-13:50 UTC Form3 experienced a degradation which resulted in some outbound payments timing out. The failure was caused by a rollout of our egress proxy during which an essential service from our cloud provider failed to start. This failure left our services being unable to egress the platform.

The issue was detected by our health checks and resolved by rolling back the change.

Form3 have identified a mitigating action that would prevent a disruption of service in the future. This action will be implemented prior to further egress rollout

Posted May 01, 2020 - 12:10 UTC

Resolved
The degradation to the Form3 Platform has recovered and normal service has resumed. 

Our Incident Response Team will continue monitoring the service to ensure there is no ongoing impact.
Posted Apr 30, 2020 - 14:29 UTC
Identified
Our Incident Response Team are monitoring our platform.

Customers will have seen submissions impacted between 14:39-14:50BST. There was no impact to admissions.

We will continue to monitor the service to ensure there is no ongoing impact.
Posted Apr 30, 2020 - 14:16 UTC
Investigating
Form3 have received an alert related to the FORM3 Platform.

Investigations are ongoing and an update will be provided when more information becomes available.
Posted Apr 30, 2020 - 13:47 UTC
This incident affected: _Archived Components (FPS RT - Indirect - Starling, FPS RT - Direct, Account Management Services, Bacs - Direct Participant, Reports, SEPA Instant - Direct).