SEPA Instant Direct Network Degradation
Incident Report for Form3
Postmortem

From approximately 10:05 - 10:30 UTC, Form3 saw a degradation in connectivity to our network provider for SEPA Instant Direct.

During this time a small number of admissions were timed out and reversed in the Form3 api, some submissions saw a brief delay before reaching final state. Impacted customers have been communicated directly regarding payments during this period.

We are working with our network provider to put in place mitigations to enhance stability of the connection to ensure greater resilience

Posted Mar 10, 2020 - 15:30 UTC

Resolved
A fix has been implemented and payments are flowing.

We were alerted to a potential connectivity issue at 10:05, as we investigated we established payments were unable to flow, the impact lasted for 25 minutes and all queues have purged, we will reconcile all impacted payments and inform customers directly should any action be required.
Posted Mar 05, 2020 - 22:47 UTC
Investigating
Form3 have received an alert related to the SEPA Instant Direct Service.

Investigations are ongoing and an update will be provided when more information becomes available.
Posted Mar 05, 2020 - 22:32 UTC
This incident affected: _Archived Components (SEPA Instant - Direct).